How to configure a Custom Domain for your Tracking page

By default, links to tracking pages in TrackMage follow this format:

[name of tracking page].trackmage.com/tracking-page/

For example, if the name of the tracking page is "mypage", the URL to it will look something like this:

mypage.trackmage.com/tracking-page/

What if you don't like this URL format and wish to change it? Perhaps, you want to a URL that is unique to your business. The good news is, you can!

With Trackmage's custom domain feature, you can change the URL to a tracking page, and in this post, you will learn how to do so. 

Step 0 Prepare your domain

Either set up CNAME records if you use Cloudflare or follow this article if you use nginx/apache web server.

Step 1

Log into your dashboard, and click the Tracking Pages tab



In this example, we have set "fake" as the default page, and it is the page we are going to be working with. If you don't know how to set a page as default, check out this tutorial

Click the Edit icon to the default page.

Step 3

In the tracking page section, click the Domain tab and then click Add Custom Domain



Step 4

In the Add Custom Domain popup box, type in the custom domain you wish to use. If you haven't set up a custom domain yet, and, perhaps, don't know how to, watch this video tutorial. It explains how to set up a custom domain with SSL certificate on Cloudflare. It's free. 

For this tutorial, we will be using "idomain.ga" as the custom domain. 


 When you are done, click the Verify button. If you set up the custom domain properly, you'd see this


Click the Save button. You will get a success message indicating that the custom domain has been set up. 

Step 5

It's now time to verify if the custom domain you've just set up is working. To do that, click the Tracking Numbers tab once more. Select any parcel, click the three dots icon beside it and copy its link.



Paste the link in your browser tab. If you noticed, the URL of the page has changed to "https://idomain.ga/tracking-pages..", indicating the custom domain set up was successful.






Did this solve your problem?